Question

sshd restart during inital server setup on cnetos7

Hi,

After I tried to add Public Key Authentication, then I added the pubic key to the new remote user following by changing the permitrootlogin to “NO” as this tutorial said : https://www.digitalocean.com/community/tutorials/initial-server-setup-with-centos-7

when I tried to reload the ssh to apply the new setting, it doesn’t and I got this error :

Redirecting to /bin/systemctl restart  ssh.service
Failed to restart ssh.service: Unit ssh.service failed to load: No such file or directory.

I tried to restart it using these both commands

systemctl reload sshd & service ssh restart

but it didn’t get restarted. When I checked it’s status, I found that it’s active and running. so what’s the solution to solve that and restart it ?

Thanks


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

The command to restart the service should be:

service sshd restart

From the output you shared it looks like you may have been running service ssh restart which referred to a service “ssh” that could not be found.