SSL and redirect issues with wordpress wp-admin page

December 23, 2014 2k views

So I signed up with cloudflare and got the universal ssl which is great. I let it propogate overnight.

This morning I checked and the ssl version of my site worked somewhat but had some minor issues. I tried a few plugins and found one that fixed the issues.

I then switched wordpress to make the homepage default to the ssl.

The site worked fine.

The wp-admin had an infinite redirect loop. No idea why.

I tried turning off plugins, to no avail.

I tried changing the site back to non https via wp-config. This makes the regular site now load without the https, so thats fine, but wp-admin still doesn't load.

Any thoughts?

The site is http://torontoboozehound.com
ssl is https://torontoboozehound.com

  • I am seeing the redirect which does appear to be between http and https. Since your site is behind CloudFlare, your attempts to resolve the issue may not have had an immediate effect due to the caching done by CloudFlare. If you access your droplet directly via the IP address does /wp-admin load properly?

  • It's possible that the caching is an issue, it concerns me that in my haste I messed something up and when the cache updates I'll be in worse trouble.

    With a proxy both http and https work but wp-admin does not.

    I should note I added the following to wp-config:


    which does not seem to do anything.

  • And wp-config does not load when accessed via the ip address. it tries to forward to ssl and probably breaks because I do not have ssl on the server, only via cloudflare.

Be the first one to answer this question.