Question

SSL Cert not working, browser Unable To Connect.

Hi I have installed an SSL cert from Comodo using both guides from their side and DO’s side. However, i am unable to access the HTTPS variant of my site.


<IfModule mod_ssl.c>
        <VirtualHost _default_:443>
                ServerAdmin admin@atk.me
                ServerName atk.me:443
                ServerAlias www.atk.me:443

                DocumentRoot /var/www/html

                # Available loglevels: trace8, ..., trace1, debug, info, notice$
                # error, crit, alert, emerg.
                # It is also possible to configure the loglevel for particular
                # modules, e.g.
                #LogLevel info ssl:warn

                ErrorLog ${APACHE_LOG_DIR}/error.log
                CustomLog ${APACHE_LOG_DIR}/access.log combined

                # For most configuration files from conf-available/, which are
                # enabled or disabled at a global level, it is possible to
                # include a line for only one particular virtual host. For exam$
                # following line enables the CGI configuration for this host on$
                # after it has been globally disabled with "a2disconf".
                #Include conf-available/serve-cgi-bin.conf

                #   SSL Engine Switch:
                #   Enable/Disable SSL for this virtual host.
                SSLEngine on
                SSLCertificateKeyFile /etc/apache2/ssl/atk-me.key
                SSLCertificateFile /etc/apache2/ssl/atk-me.crt
                SSLCertificateChainFile /etc/apache2/ssl/atk-me.ca-bundle

Above is my ssl configuration.

Any help will be greatly appreciated.

If it helps, my certificate is under Comodo and is reissued.

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Fixed it by commenting out the :

A self-signed (snakeoil) certificate can be created by inst$

            #   the ssl-cert package. See
            #   /usr/share/doc/apache2/README.Debian.gz for more info.
            #   If both key and certificate are stored in the same file, on$
            #   SSLCertificateFile directive is needed.
            #***SSLCertificateFile     /etc/ssl/certs/ssl-cert-snakeoil.pem***
            #***SSLCertificateKeyFile /etc/ssl/private/ssl-cert-snakeoil.key***

Strange that no one seemed to point this out.