Question

SSL Certificate issues only on Android Chrome?

So I installed a SSL certificate on a subdomain and everything worked fine for desktop Chrome and IE but when I use android chrome I get the following error… ERR_CERT_AUTHORITY_INVALID

Looking at the certificate it appears to only have only 1 certificate, the website’s, but not the root or intermediate. It is a class 1 certificate from StartSSL and this is my ssl virtual host config for my subdomain

SSLEngine on SSLProtocol all -SSLv2 SSLCipherSuite ALL:!ADH:!EXPORT:!SSLv2:RC4+RSA:+HIGH:+MEDIUM

SSLCertificateFile /etc/apache2/ssl/cloud/ssl.crt SSLCertificateKeyFile /etc/apache2/ssl/cloud/private.key SSLCertificateChainFile /etc/apache2/ssl/sub.class1.server.ca.pem


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

If someone has the issue play market there’s a much more simple solution. Here’s the instruction on resolving device uncertified trouble

@Nathan485 could you try this configuration ?

SSLEngine on
# Please no SSLv3
SSLProtocol all -SSLv2 -SSLv3
SSLCipherSuite EECDH+AESGCM:EDH+AESGCM:AES256+EECDH:AES256+EDH
SSLCertificateFile /etc/apache2/ssl/cloud/ssl_unified.crt
SSLCertificateKeyFile /etc/apache2/ssl/cloud/private.key
SSLCertificateChainFile /etc/apache2/ssl/cloud/sub.class1.server.sha2.ca.pem

Restart Apache2

Normally you don’t need to do this after a Certificate merge. If it is still not working, reinstall Apache2.

This comment has been deleted