Question

SSL Certificate with error

  • Posted on September 5, 2014
  • caponeAsked by capone

Hi People.

We got certificate from Geotrust and try to install in server ubuntu - apache2 - openssl but show to us everytime same error: AH01909: RSA certificate configured for www.xxx.com:443 does NOT include an ID which matches the server name

The conf apache file is correct same instructions:

<VirtualHost xxx.com:443>
  ServerAdmin webmaster@xxx.com
  DocumentRoot "/var/www/xxx/htdocs"
  ServerName xxx.com
  DirectoryIndex index.html index.php
  ErrorLog /var/www/xxx/log/ssl_error.log
  TransferLog /var/www/xxx/log/ssl_access.log
  SSLEngine On
  SSLProtocol all

  ServerPath "/var/www/lenharomegastore/htdocs"


  SSLCertificateFile /var/www/xxx/ssl2/xxx.crt
  SSLCertificateKeyFile /var/www/xxx/ssl2/xxx.key
  SSLCertificateChainFile /var/www/xxx/ssl2/positive_bundle.crt
  SSLCACertificateFile /var/www/lenharomegastore/ssl2/positive_bundle.crt

  <Directory "/var/www/XXX/htdocs">
     AllowOverride All
     Options Indexes Includes FollowSymLinks
     Order allow,deny
     Allow from all
  </Directory>
</VirtualHost>

We already verified if certificate is perfect with command

openssl x509 -in lenharomegastore.crt -noout -subject

and show to us

subject= /OU=Domain Control Validated/OU=PositiveSSL/CN=xxx.com

Thanks a lot friends


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

add the following to virtualhost configuration

ServerAlias www.xxx.com RewriteEngine On RewriteCond %{HTTP_HOST} ^www(.)$ RewriteRule ^(.)$ https://xxx.com [R=301,L]

This comment has been deleted

This comment has been deleted