Question

SSL configuration sends me to default NGINX page

I have followed the steps on: https://www.digitalocean.com/community/tutorials/how-to-secure-nginx-with-let-s-encrypt-on-ubuntu-16-04

I have no modified the Nginx default configuration other than changed the server name according to STEP 2 from the above instructions, using the main domain and the www version.

The rest remains as in: https://api.coderrocketfuel.com/assets/nginx-default-configuration-file.txt

The certifinate is for a subdoain. So in STEP5 I successfully obtained certificate for the subdomain

However, when I try to access subdomain it says:


Welcome to nginx!

If you see this page, the nginx web server is successfully installed and working. Further configuration is required.

For online documentation and support please refer to nginx.org. Commercial support is available at nginx.com.

Thank you for using nginx.


In the droplet I have an app developed with Vue.js installed on an Ubuntu 16

I was wondering if someone could help me with this, because there is something that I am missing.

thanks


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi there @Bubusi,

It sounds like that the wrong Nginx server block configuration file is being used.

I would recommend checking the content of your /etc/nginx/sites-enabled folder and verify that you’ve change the server name in the correct file.

Feel free to share the rest of the Nginx server block configuration files here.

Let me know how it goes. Regards, Bobby