Question

SSL connection error - ubuntu / apache

  • Posted on October 22, 2014
  • jwbAsked by jwb

Hey,

Apologies first of all, because I basically have no idea what I’m doing, so please be patient with me!

I’ve just started up a new droplet which has Ubuntu / Apache and Wordpress on and I got a free .me domain and PositiveSSL cert from namecheap (using the Github student pack) …but unfortunately I’m having issues with the SSL setup.

I followed the comodo guide for obtaining a .csr + .key (goo.gl/rKkUHc), opened/copy/pasted the csr into namecheap’s application box, and went though the process of obtaining the certificate files from comodo. I enabled the a2enmod ssl thing, and finally followed Comodo’s guide to install the certificate and .key (goo.gl/WaklqY) before restarting apache.

…Unfortunately, no matter what I seem to do, I can’t seem to find anything that fixes my issue, or I just fail to understand what people are talking about when searching through google.

The only changes that I basically made were adding the certificate/key files to /etc/ssl/ssl.key and ssl.crt folders that I created, and also editing the /etc/apache2/sites-enabled/default-ssl.conf to change the file names / locations.

So, I’m kinda stumped, I don’t know if there’s something I’ve missed, or whatever, but any help would be much appreciated, Thanks!


p.s. The error I get when trying to connect to https://mysite.me OR https://www.mysite.me (as the certificate covers both) using chrome, is:

Unable to make a secure connection to the server. This may be a problem with the server, or it may be requiring a client authentication certificate that you don't have.
Error code: ERR_SSL_PROTOCOL_ERROR
Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi. I had the same problem - wanted to secure the phpmyadmin page. Turned out that the default-ssl.conf was not enabled by default (the apache2 default configuration for https pages).

To fix this run: a2ensite default-ssl.conf Don’t forget to: service apache2 reload

This comment has been deleted