I created the Storage and connected to my site using the API key. Everything works fine, files are downloaded and deleted. When I try to connect a subdomain, and configure a DNS record on my CNAME server (to work as s3.mydomain.com), my SSL (lets encrypt) certificate does not pull me up although I added it in the CDN space settings, but the subdomain was defined like www.mydomain.com and not like s3.mydomain.com and nothing works, what am I doing wrong?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
4 answers

Hello,

May I ask if you’ve installed SSL Certificate for s3.mydomain.com? If you have a wildcard SSL you can use this one and install it for the subdomain. If you don’t have SSL for s3.mydomain.com you can use certbot to install a Let’s Encrypt SSL for s3.mydomain.com

Alex

Hey. lets encrypt silence should have a wildcard ??? Since I create a subdomain through the CNAME of the main domain, my ISP server control panel does not provide for a separate certificate generation for the subdomain. How to proceed?

  • Hello,

    If you have root access to your server you can issue and install the SSL Certificate manually using certbot. If you can let us know the specification of your server - OS, distribution, I can provide you with additional information.

    Alex

    • Hello! I figured out SSL, it worked, after generating the certificate for the subdomain.

      • Could you help me about generating the certificate for the subdomain? I got the same problem, but I haven’t found the way.

        I use CName (created from Godaddy) and point to Amazon S3. For example: img.mysite.com point to s3-ap-southeast-1.amazonaws.com.

        Everything is OK, but how to procedd SSL for my subdomain (img.mysite.com).

        Many Thanks…

      • Hello, @romanterziev

        Thanks for confirming this!

        Regards,
        Alex

      • Hello

        I am having exactly the same problem.

        My domain is on NAMECHEAP and have created a cname for my storage. Everything works, add/remove file. However I have no ssl on the cname.

        For example. Mydomain.com is on NAMECHEAP. I created sub.mydomain.com. the sub is the cname, I have successfully connected it to my storage.

        Now I need to attach an ssl to the subdomain, I have gone the steps on DO but I am not able create a subdomain in DO as my domain is hosted with NAMECHEAP.

        Any help would be appreciated as my website is currently not functioning.

        Thank you

Hello, @solomenmarketing

Could you please let me know what have you done so for and on which step you’re currently experiencing issues? You’ve mentioned that the CNAME is created but you can’t proceed with the SSL install. Could you please expand more on this, are you receiving any error messages and how exactly you’re trying to issue/install the SSL?

Regards,
Alex

Hi, @Kay86

If the active DNS zone for your domain name is with NAMECHEAP (your domain name is using their nameservers) then you need to create the subdomain from their control panel and not from your DigitalOcean account.

Hope that this helps!
Regards,
Alex

Submit an Answer