SSL Failing to renew

Posted August 31, 2018 5.8k views
ApacheLet's EncryptUbuntu 16.04

I’m running a LAMP stack with LetsEncrypt cert. My cert exprie and is failing to renew.

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator apache, Installer apache
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for
http-01 challenge for
Waiting for verification...
Cleaning up challenges
Failed authorization procedure. (http-01): urn:ietf:params:acme:error:connection :: The server could not connect to the client to verify the domain :: Fetching Error getting validation data

 - The following errors were reported by the server:

   Type:   connection
   Detail: Fetching
   Error getting validation data

   To fix these errors, please make sure that your domain name was
   entered correctly and the DNS A/AAAA record(s) for that domain
   contain(s) the right IP address. Additionally, please check that
   your computer has a publicly routable IP address and that no
   firewalls are preventing the server from communicating with the
   client. If you're using the webroot plugin, you should also verify
   that you are serving files from the webroot path you provided.

I used this instructions
I pick the option that for https only.

Any suggestions ?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
5 answers

It seems like your domain is pointing to the correct IP address. You should check if you have proper permissions set for domain document root.

And see if there is a .well-known directory within the document root. You can check it with,

ls -a /path/to/public_html

I checked that and everything is fine, but I still getting the error.

I talk to LetsEncrypt and they said that my server is serving http over https

You should check if you have proper permissions set for domain document root.


I’ve fixed this LetsEncrypt error for @ae3erdion

I had the same error during renewal because of my misconfigured firewall.

I ran sudo ufw allow 'Nginx Full' so that certbot could access my server with unencrypted traffic on port 80 and that solved the problem.