SSL not working on Apache Ubuntu 12.04

September 3, 2014 1.8k views


I followed various guide and installed my SSL Certs. I have upload three files to my ~/ssl/* directory:

1.) mydomain.crt (SSLCertificateFile)
2.) mydomain.key (SSLCertificateKeyFile)
3.) (SSLCertificateChainFile)

I have edited my server config file and included <VirtualHost *:443> beneath <VirtualHost *:80> (all config in one file). Now when I open the site without "https", it works fine, but when I open with "https", the browser (after long wait) says "Unable To Connect". I think I'm (being a noob) not able to understand a small clue or a glitch or an error. I suspect I'm doing something wrong with the third file (SSLCertificateChainFile).

Can you please help?

PS: My UFW is set to allow traffic on port 443.

1 comment
  • You should check your Apache error logs to see if there is any information there, but also depending on how you defined your <VirtualHost> line as well as prior directives you may have instructed Apache to only listen on port 80 in which case it would ignore the SSL virtual host that you added.

    Check your config to see if you have a Listen directive there outside of the virtual host.

    Outside of that can you also paste your httpd.conf with your virtual host definition, feel free to remove things like path's since they aren't important.

1 Answer

My DNS (cloudflare) was blocking SSL connections. Figured out lately. Setting were correct as explained in DO's tutorial.

Thanks for your support!

Have another answer? Share your knowledge.