Question

SSL not working on server

I am having problems getting SSL going on the server I followed the following instructions here for Apache

https://www.digitalocean.com/community/tutorials/how-to-install-an-ssl-certificate-from-a-commercial-certificate-authority

and my SSL certificate isn’t working here is my vitutal host configuration

# Added to mitigate CVE-2017-8295 vulnerability
UseCanonicalName On
<VirtualHost *:443>
        ServerAdmin webmaster@localhost

        ServerName $domain
        ServerAlias www.$domain
        Redirect permanent / https://abovepath.ca

        SSLEngine on
        SSLCACertificateFile      /etc/ssl/certs/4f48e133ed38192c.crt
        SSLCertificateKeyFile  /root/abovepath.ca.key

        DocumentRoot /var/www/html



        <Directory /var/www/html/>
            Options FollowSymLinks
            AllowOverride All
            Require all granted
        </Directory>

        ErrorLog ${APACHE_LOG_DIR}/error.log
        CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

This is what the issue was. You need to be in the following folder when a new droplet is created.

/etc/apache2/sites-enabled

Hello,

I believe that Apache might not have access to the /root/ directory. So Apache is failing to read the key.

I would recommend moving your key to /etc/ssl/ for example and then testing this again.

Let me know how it goes! Regards, Bobby