Question

SSL not working on WordPress site

I’ve looked through lots of questions on this, but can’t seem to figure this out. I followed the one-click WordPress install and set up a Let’s Encrypt SSL, but https isn’t working on my site, and after following a recommendation to change the URL in the settings within Wordpress from http to https, I can no longer even get into wp-admin (since it’s forwarding to https). The main site works, but only on http. Can anyone give me some guidance?

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

I’m having the same issue. I checked and the file is there. So why isn’t resolving to https?

This comment has been deleted

Hi @caretx,

Usually when installing the one-click Wordpress application in the setup (in yout terminal) it ask if you want to first install Let’s Encrypt and the redirect to https. Did you go through those options?

Additionally, can you confirm if you have an SSL configuration file created on the droplet as well. It should be located in the /etc/apache2/sites-enabled and the conf should be named 000-default.conf.

If this hasn’t been created what I’ll recommend is use certbot, you should already have it installed by default on the droplet. The following command should help you wit that as well

sudo certbot --apache -d your_domain -d www.your_domain

Regards, KFSys