Question

SSL problem with OpenLiteSpeed WP

Posted July 24, 2019 766 views
DigitalOcean OpenLiteSpeed WordPress 1-Click

Hello, This is my droplet: 165.22.75.184
I have linked it with the domain: perfectfoodblog.com

The problem is getting the SSL certificate working.
followed this guide: https://docs.litespeedtech.com/cloud/wordpress/#step-1

I rebuild a dropled which was linked to the domain already (A records are pointed to the server).
Then I accessed the console and went through step-by-step guide to get let’s encrypt certificate.
Then I installed the wp.
I added listeners, mappings and rewrite rules in LiteSpeed panel too.
But the problem still exists:
When I enter the address in browser, It changes to server IP and SSL won’t work, instead it shows insecure connection (because SSL certificate is generated on the domain name).

I changed website address from WP settings to https://perfectfoodblog.com. Now when I access https://perfectfoodblog.com/wp-admin it works great (browser sees valid certificate) but when I go to “front”, it still shows IP address instead of domain name :/

Any suggestions?

Thanks

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

2 answers

Hello,

I tested your website and it seems to be working perfectly fine with the SSL certificate.

Would you mind shearing how you fixed the problem? Did you have to just change your site and home URLs in your WordPress?

Thanks!
Bobby

Hi,

Like Bobby said, domain works fine to me as well.

Generally you only need to setup domain,ssl,force https by following Doc Step 3 which should be faster and much easier.

When you visit front and it bring you to the IP probably due to browser cache. Please try it again with different browser or incognito view.

Best,
Eric

Submit an Answer