Question

SSL Redirection Certbot / Too many redirects / Nginx Default page shows on Server IP

Hi,

First time writing here, Hope someone could help.

I have a domain DNS pointed as below:

A RECORD

@ pointed to SERVER_IP www pointed to SERVER_IP

I am not using CNAME as I was following tutorial on Digital Ocean. Let me know if that is the route I should go for.

Anyways, I followed all the tutorial as mentioned in Initial Ubuntu Server and Also Lemp Install. Nginx Installed, PHP working good.

Then I try to install SSL Certificate using Certbot. CertBot Tutorial finished with no errors however, My website is not having redirection error. I selected redirect all http to https since my goal is that

http://DOMAIN.tld should forward to https://www.DOMAIN.tld http://www.DOMAIN.tld should forward to https://www.DOMAIN.tld

Also note if I enter my SERVER_IP in browser it was showing nginx default page. I removed unlink default from the /sites-enabled/ I’m not sure if that is the cause of the error.

Please let me know what am I doing wrong since I’m stuck here for a long time.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi there @adilrazadxb7,

Can you share your Nginx server blocks from the sites-enabled folder? Also, was the site working as expected before adding the SSL certificate?

It is possible that you either have an incorrectly set document root or that the server name was not specified in the Nginx server block.

Another possible problem is that if you are using a CMS like WordPress, you might have to update your Site and Home URLs from http to https too.

Regards, Bobby