Question

start a service only after mysql has entered Active (running) state

I have a service that requires mysql to be fully up and running before it starts otherwise it fails. I have very alrge mysql databases and mysqld takes up to 40 minutes before entering an active (running) state.

I have tried adding After=mysqld.service in the secondary services .service file {unit] section without success. It starts my secondary service ass soon as mysqld is enabled. I have tried using Wants=mysqld.service and Requires=mysqld.service without success.

Any help or suggesstions would be appreciated.

Thank you


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Generally, to declare a strict dependency, you will want both After and Requires:

[Unit]
Description=My application 
After=mysqld.service
Requires=mysqld.service

If for some reason you’re still not have the expected behavior, another option would be to use a script in ExecStartPre that blocks until it can connect to the database. wait-for-it is a useful tool for this: https://github.com/vishnubob/wait-for-it

For more info on working with systemd unit files, check out: