Question

Still getting a "welcome to nginx" page

I moved all my angular 4 files into the default /usr/share/nginx/html and its still showing the blank welcome to nginx page… What else am I supposed to do?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Just for tips, in my case it’s because I missed these in config files

    include       mime.types;
    default_type  application/octet-stream;
    

Hi @brayanbyrdsong

In your Nginx site configuration, is the root directive set to /usr/share/nginx/html ? Your site configs are located in /etc/nginx/sites-enabled/

If you want to continue to use the /usr/share/nginx/html instead of a custom location, then delete the file index.html in the directory before adding your content.