I moved all my angular 4 files into the default /usr/share/nginx/html and its still showing the blank welcome to nginx page… What else am I supposed to do?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
2 answers

Hi @brayanbyrdsong

In your Nginx site configuration, is the root directive set to /usr/share/nginx/html ?
Your site configs are located in /etc/nginx/sites-enabled/

If you want to continue to use the /usr/share/nginx/html instead of a custom location, then delete the file index.html in the directory before adding your content.

Just for tips, in my case it’s because I missed these in config files

    include       mime.types;
    default_type  application/octet-stream;

Submit an Answer