Question

Strapi droplet is not secure(using only http) causing an error to login

Posted November 15, 2020 120 views
SecurityDigitalOcean DropletsStrapi

I created a website using ‘Gatsby.js’ and tried to use Strapi droplet which is hosted in digitalocean.
However after I added all the data to the backend and tried to log in my website, I see this error and can’t log in:

**login.js:25 Mixed Content: The page at 'https://myWebsite.com/login' was loaded over HTTPS, but requested an insecure resource 'http://188.1xx.1xx.251/auth/local'. 
This request has been blocked; the content must be served over HTTPS.**

So I looked at my droplet and found out that it’s not using https!
http://188.1xx.1xx.251/auth/local

When I created this site, I didn’t use ssl option. So I created another droplet which is using ssl, but it still using 'http’, not 'https’.

So my website is pretty much useless since I can’t log in.
Is there anybody who can help me with this please?

edited by bobbyiliev

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Hi there @izzyangelworld,

I believe that you have to edit your Strapi config and specify your domain name as the host rather than your Droplet’s IP address, that way the resources will be loaded directly from your domain rather than your IP address, which will fix the mixed content error.

You can take a look at how to do that here:

https://strapi.io/documentation/v3.x/deployment/nginx-proxy.html#strapi-server

Regards,
Bobby

Submit an Answer