Stuck: can't type anything in console acces

  • Posted on May 26, 2014
  • penceaAsked by pencea

I was setting up PHP over Nginx when all of the sudden my console access stoped working. It displays what it should but cat’t type any character. Tried refresh, changed the computer but the problem persists.

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

I have the solution! To those who are stuck click on the window and press one of these combinations.

CTRL+X CTRL+C CTRL+(anything)

one of the letters will end up “exiting” the program that is running. Allowing you to type again!

The Digital Ocean console did not work for me either. I tried to add an SSH key to .ssh/authorized_keys with the DO console because I could not SSH into the droplet from a new computer because of “permission denied (publickey)”. When I pasted in my new SSH key, it got altered. For example “ssh-rsa” became "ssh_rsa" and upper-case letters became lower-case letters and the whole string was cut off at some random point. Then the console became unresponsive and wouldn’t let me type anything at all. I had to google and eventually typed Ctrl+c at the command prompt repeatedly and reloaded the console repeatedly until I could type again. The pico and nano editors don’t work properly either. And there was no way I could add an SSH key because pasting doesn’t work and I didn’t want to type in my SSH key manually into the non-working nano editor. To sum up, it’s a completely unusable POS.

Tried CTRL + C ended up CMD + CTRL + C worked for me.