Subdomain in Apache2 VirtualHost is being ignored

February 7, 2019 507 views
Apache DNS Ubuntu 16.04

Hi all,

On lists.example.org I want to run Mailman3. Mailman3 works perfectly in a Docker Container on my Droplet.

So I wrote a VirtualHost like this:

<VirtualHost *:443> 

    ServerName lists.example.org
    Include /etc/letsencrypt/options-ssl-apache.conf
    SSLCertificateFile /etc/letsencrypt/live/example.org/fullchain.pem
    SSLCertificateKeyFile /etc/letsencrypt/live/example.org/privkey.pem
    ServerAdmin donald@trump.org
    Alias /static /opt/mailman/web/static
    Alias /favicon.ico /opt/mailman/web/static/hyperkitty/img/favicon.ico
    ProxyPassMatch ^/static/ !
    ProxyPass / http://172.19.199.3:8000/
    ProxyPassReverse / http://172.19.199.3:8000/

    <Directory />
    Allow from all
    Require all granted
    </Directory>

    <Directory /opt/mailman/web/static/hyperkitty/img/>
    Allow from all
    Require all granted
    Options FollowSymLinks
    </Directory>

    <Directory /opt/mailman/web/static/>
    Options FollowSymLinks
    Allow from all
    Require all granted
    </Directory>

</VirtualHost> 

When I access lists.example.org, nothing is being displayed. But I can perfectly establish a connection to lists.example.org on port 443.
Now comes the weird part: example.org displays the mailing list. So somehow the subdomain lists is being ignored.

This seems like a simple problem but I have found so many misleading tutorials..

2 Answers

It seems as if the SSL cert you have in the vhost is not for lists.example.org. So if you don’t actually have the SSL cert for lists.example.org in the vhost block, it’ll translate to going to https://IP/ instead and that would just go to the first virtualhost that apache has loaded at runtime.

Now as to why https://example.org pulls this vhost is unclear from the info you have up there.

Cheers

Thanks, I got it working!

Have another answer? Share your knowledge.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!