Question

suphp and mcrypt

  • Posted on June 6, 2014
  • robbiebAsked by robbieb

Trying to setup a server to test a magento shopping cart. I thought I had everything setup but apparently not. When I try to configure a new magento cart I get this warning: PHP extension “mcrypt” must be loaded.

I’m unable to continue because of this.

My droplet is ubuntu 14.04

apt-get install apache2 php5 php5-mcrypt php5-gd php5-curl libapache2-mod-php5 mysql-server mysql-client php5-mysql libapache2-mod-suphp vftpd

my suphp.conf reads like this

<IfModule mod_suphp.c>

<FilesMatch “.ph(p3?|tml)$”>

SetHandler application/x-httpd-suphp

</FilesMatch>

    AddType application/x-httpd-suphp .php .php3 .php4 .php5 .phtml
    suPHP_AddHandler application/x-httpd-suphp

<Directory />
    suPHP_Engine on
</Directory>

This droplet is replacing an old server that was configured a couple of years back. I always had permission problems until someone installed suphp for me. Although suphp wasn’t installed till quit some time after the previous server was provisioned so not sure if I should just temporarily disable suphp just to proceed and then enable it after, or if I’m just not configured properly.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Make sure php5-mcrypt is enabled: <br> <br><pre> <br>sudo php5enmod mcrypt <br>sudo service apache2 restart <br></pre>