Question

swap debian 7 64 bits

Hi, I have the 1 GB RAM 30 GB Disk vps. I added the swap looking at another question (SWAPFILE) [code] echo “vm.swappiness=0” | sudo tee -a /etc/sysctl.cnf

sudo sysctl -p

sudo dd if=/dev/zero of=/swapfile bs=1024 count=256k

sudo mkswap /swapfile

sudo chown root:root /swapfile

sudo chmod 0600 /swapfile

sudo swapon /swapfile

echo “/swapfile none swap sw 0 0” | sudo tee -a /etc/fstab [/code] Is this ok.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

@Igor: That is correct, but renaming sysctl.cnf to sysctl.conf replaces sysctl.conf and removes the old settings.

In debian 7 no sysctl.cnf file. It has sysctl.conf file.

I recommend not doing that but fixing it by deleting and re-appending instead: <br> <br><pre>rm /etc/sysctl.cnf <br>echo “vm.swappiness=0” | sudo tee -a /etc/sysctl.conf <br>sysctl -p</pre>