Question

swapon: /swapfile: swapon failed: Operation not permitted

Posted December 17, 2019 5.5k views
Debian
composer update

Does not run due to low memory on a droplet with 2GB.

But swapon operation is not permitted here: “swapon: /swapfile: swapon failed: Operation not permitted”

Followed https://www.digitalocean.com/community/tutorials/how-to-add-swap-space-on-ubuntu-18-04 to no avail - cannot enable swap in the last step.

What else can I do to enable swap, even if temporarily?

Thanks!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Hi @avayaphone,

This might be a really long shot however, can you try using sudo

sudo swapon: /swapfile

It should help with your problem. If it still exists, please make sure you have the correct ownership and permission on the swapfile. To do so, type in

sudo chmod 600 /swapfile

Regards,
KDSys

Submit an Answer