Question

Swappiness doesn't work as expected

Hi,

you can fin below an extract of what I have on my droplet (Ubuntu 14.04.5 LTS):

System information as of Sat Apr 11 04:50:46 EDT 2015

System load: 0.01 Processes: 89 Usage of /: 62.2% of 19.56GB Users logged in: 0 Memory usage: 68% IP address for eth0: 178.62.7.107 Swap usage: 0%

root@droplet1:~# free -m total used free
Mem: 993 834 158
-/+ buffers/cache: 668 324 Swap: 4095 0 4095 root@droplet1:~# cat /proc/sys/vm/swappiness 90

So normally, by setting up swappiness to 90, I should have the swap used as soon as more than 10% of my RAM is used, but it is not the case, someone already ran into that problem with DO? on my other stations it works good.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Sorry for the indenting I can’t make it look like when I edit it