Question

Sync to Spaces Re-uploads every time

I have tried both rclone and aws s3 sync commands to sync data from my server to spaces. Both upload fine, but on subsequent syncs, the data re-uploads again. This is a big problem as I have over 500GB data spanning 28,000 files.

I am using command like this for aws:

aws s3 sync --endpoint=https://nyc3.digitaloceanspaces.com shows/108 s3://MYSPACECONTAINER/shows/108

I am at a loss. I have done this with no problem at Amazon, but DO is causing me headaches.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hello, @marcpope

I have tried this with rclone and the files are not re-uploaded again.

I’m using Linux and the following command is working fine for me:

rclone sync space:/Books /home/sammy/books

Additionally you can add -vvv for more verbose output. This can help us with the troubleshoot process.

Hope that this helps! Regards, Alex