Temporary Lookup Failure - Postfix & Dovecot

March 20, 2015 5.7k views
Email DigitalOcean DNS Ubuntu

Hey all!

I'm trying to setup a Mail Server on a Droplet. I've got everything working as far as connecting to Outlook goes, but when I try to send a message, I get [this](http://).

Here's some files of potential interest to help fixing the issue.


If you need anything else, please let me know.

Thanks in advance for the help!

3 Answers
  • If that worked, I wouldn't be here.

    I've made sure /etc/aliases is completely correct and ran "sudo newaliases" as well as restarted Postfix, even the server.

    Hell, I'll even throw in a copy of my Aliases file!


Can you do nslookup from your droplet? Do things resolve?

This is part of my main.cf:

smtpdrelayrestrictions = permitmynetworks permitsaslauthenticated deferunauthdestination
myhostname = DOMAIN.com
maps = hash:/etc/aliases
aliasdatabase = hash:/etc/aliases
myorigin = mail.DOMAIN.com
mydestination = localhost
relayhost =
mynetworks = [::ffff:]/104 [::1]/128
sizelimit = 0
delimiter = +
inetinterfaces = all
protocols = all

smtpdclientrestrictions = permitmynetworks, permitsaslauthenticated, rejectunauthdestination, rejectrblclient zen.spamhaus.org, rejectunknown_hostname, permit

  • Did "nslookup mail.ebear.us", everything seemed normal. Nothing that is incorrect.

    Those settings are pretty much the same as mine (substituting the IP's, of course).

    Still not working. Any ideas?

No. Can your server resolve the domain you were sending to, and has it valid mx records?

  • I've setup this MX record:

    ebear.us. 1800 IN MX 10 mail.ebear.us.

    Outlook is able to connect to the server and stuff. Sending mail via SquirrelMail works, however it's not optimal for any circumstances as it's kinda annoying to use and all that.

    So the weird part is why it's working internally but not externally.

Have another answer? Share your knowledge.