toul-10
By:
toul-10

The domain name showing the ip adress instead of the domain

September 11, 2014 4.4k views

I am trying to figure out what happens and my domain showing the ip adress. I point the ip adress on the server configuration the website showing fine but as a url showing the ip adress.
Any ideas how to solve that issue?

3 Answers

Whats your domain? Did you change the nameservers with your registrar to point to DO? And did you added the domain in the DO panel?

  • now i change the path because i create a new virtual domain as pairno.gr and redirect to the old path var/www/magento

    <VirtualHost *:80>
            ServerAdmin webmaster@pairno.gr
    
            DocumentRoot /var/www/pairno.gr/public_html
            ServerName pairno.gr
            ServerAlias www.pairno.gr
            <Directory />
                    Options FollowSymLinks
                    AllowOverride None
            </Directory>
    
  • You need to go to digital ocean control panel and under the DNS tab click 'add domain' on the top right corner. Also you need to go to whoever you register your domain with and change nameservers to ns1.digitalocean.com and ns2.digitalocean.com

    It looks like your domain is register with papaki.gr as your nameservers right now are pointing to

    dns1.papaki.gr
    dns2.papaki.gr

    Hope this solves your issue

  • i work with papaki and use A record. if you check the following domain that is in the same server works file www.ktoulis.com
    Something going wrong with my configurations

  • Check out this tutorial it might give you some more info

    by Etel Sverdlov
    This tutorial shows you how to set up a new directory, how to grant the correct permissions, how to add content to a new page, how to turn on virtual hosting, and how to, if needed, set up local hosts. Virtual Hosts are used to run more than one domain off of a single IP address and allows you to run multiple sites off of a single DigitalOcean droplet. This tutorial describes how to set up virtual hosts with Apache.

A little late but found a simple fix to this...

After getting all your cname/aliases set up, you would go to General settings->change "Site Address (URL)" to whatever your domain is. By default, it will list your site's IP address.

Tested on Wordpress with Ubuntu 16.04

Thanks for that @plouie21 - just to mention that the General settings bit is within wordpress, I thought you meant that this was within the digitalocean control panel.

Have another answer? Share your knowledge.