Question

The health check interval unit isn't in seconds

Hello.

I’ve setup a load balancer with my Kubernetes service with type: LoadBalancer. I noticed that health check requests came in at a really fast pace (2 requests per second). I got curious and checked the interval and it was set to 5 and the unit indicated on the UI says (s) which I assumed it means seconds.

I play around with the settings and found out that if I set the value to 50 instead of 5 then health check requests came in at every 5 seconds. Is there a misconfiguration or the unit label should be changed to (0.1s)?

Could you also clarify on other settings as well?

Thanks.

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer