Question

"The requested URL was not found on this server." Even after setting up name servers and A record.

Using Ubuntu 16.04 LAMP

keep getting this: The requested URL was not found on this server. After setting up name servers and A record.

I set up name servers on GoDaddy and the A record and nameserver on digital ocean but still am getting not found. I tested the connection from command line with host command for all three digital ocean servers and I get the correct IP address back. Also, tested this with host command with ISP and also received the correct IP address. I can also access the website from a browser with the IP but not domain name. Any help would be greatly appreciated!


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

"In case you are on Ubuntu, edit the file /etc/apache2/apache2.conf (here we have an example of /var/www):

<Directory /var/www/> Options Indexes FollowSymLinks AllowOverride None Require all granted </Directory> and change it to;

<Directory /var/www/> Options Indexes FollowSymLinks AllowOverride All Require all granted </Directory> then,

sudo service apache2 restart You may need to also do sudo a2enmod rewrite to enable module rewrite."

I’m having the exact same problem,

this is the first time I’m having trouble with this after doing it many times. I think it’s because of a change in the process of the one-click wordpress install… It now asks you to write the domain/subdomain name in the terminal when you’re accessing root for the first time.

What solved it for me (wordpress image based on ubuntu 18) was going to Settings -> Permalinks, and simply pressing save.

got the answer from https://wordpress.stackexchange.com/questions/253245/wordpress-migration-getting-404-errors-only-home-page-works