Question

The requested URL /xxxxxx was not found on this server. Apache/2.4.29 (Ubuntu) Server at 178.128.75.206 Port 80'

Posted July 30, 2018 26k views
UbuntuApacheConfiguration Management

This is my first time using digitalocean and I am completely new to apache configuration etc.

I have a php application hosted on ubuntu 18.04. After uploading web files, the homepage or default ip address goes through but other links don’t. i get the error, ‘The requested URL /xxxxxx was not found on this server. Apache/2.4.29 (Ubuntu) Server at 178.128.75.206 Port 80’

The ip address is of my website is 178.128.75.206 .

The requested URL /digitalsaving was not found on this server.

Apache/2.4.29 (Ubuntu) Server at 178.128.75.206 Port 80’

My config file looks like this [/etc/apache2/sites-available/stash.ng.conf]

<VirtualHost *:80>
ServerAdmin webmaster@stash.ng
ServerName stash.ng
ServerAlias www.stash.ng
DocumentRoot /var/www/stash.ng/html
<Directory /var/www/stash.ng/html>
Options +FollowSymlinks
AllowOverride All
Require all granted
</Directory>

ErrorLog ${APACHE_LOG_DIR}/error.log
CustomLog ${APACHE_LOG_DIR}/access.log combined

</VirtualHost>

Thanks in advance

1 comment
  • You probably need some mod_rewrite rules. What is the php application you’re using?

    And see if you have a .htaccess file in the document root.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
4 answers

I am facing the exact same issue. Can you please update how you had solve this issue?

HI,

I came across the same obstacle while establishing a Database connection through PHP and MySql. if anyone can elaborate detail solution it would be great. Thanks :)

You can sign in to your WordPress and go to Permalink Settings, using this format in Custom Structure /*/%postname%/

Submit an Answer