Question

The server responds with the IP address but not with the domain name

Posted July 16, 2020 88 views
DNS

I have seen some queries and I have tried to solve but I have not succeeded, I have basically published a wildfly which I access from any browser, putting the IP address and the listening port example: ##.##.##.##:port, and it works great, I bought a domain name and followed the procedure to delegate it to digitalocean’s DNS (ns1.digitalocean.com, ns2 …) additionally when it didn’t work, add hostname www to the domain to try to enter www.sitename.com:port but it still doesn’t work for me, any idea what is my problem?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Hi @rramirezech,

You’ll need to add the domain to your WebService. Your WebService is either Nginx or Apache. If you are unsure which one you are using, you can easily check by going to your droplet via SSH and typing the following command

netstat -tulpen | grep 80

This will output what’s listening on port 80. If it’s Apache2/httpd, then you are using Apache, if it shows Nginx, well then it’s Nginx.

Now, based on the output, I’ll recommend you checking one of the following articles on how to create your virtual configuration (vhost) so that your domain actually works porperly.

If it is Apache, check out the following article:

https://www.digitalocean.com/community/tutorials/how-to-set-up-apache-virtual-hosts-on-ubuntu-18-04

If it is Nginx :

https://www.digitalocean.com/community/tutorials/how-to-set-up-nginx-server-blocks-virtual-hosts-on-ubuntu-16-04

Regards,
KFSys

by Justin Ellingwood
When using the Nginx web server, server blocks (similar to the virtual hosts in Apache) can be used to encapsulate configuration details and host more than one domain off of a single server. In this guide, we'll discuss how to configure server blocks in Nginx on an Ubuntu...
Submit an Answer