Question

Theme will upload via FTP but not show up in WP UI

  • Posted May 24, 2014

Just spun up a Ubuntu 14, NIGINX droplet and got the non-root user created, and everything for WordPress is installed and working.

Tried adding a new theme and it asks for the Hostname (IP address at this point) FTP/SSH Username/Password (my non-root info) but then it asks for my Authentication Keys on the server, public and private…where would they be again? Or is my issue a file path permission issue? I am able to edit and create posts and pages but hit the same wall when attempting to install a plugin.

I used these articles to get here:

Did some looking around and thought someone was having a similar issue so I tried some of their solutions with little luck:

I am kinda new, so its entirely possible that I am missing an easy initial step.

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

The paths should be <code>/home/wp-user/wp_rsa</code> and <code>/home/wp-user/wp_rsa.pub</code>. wp-config.php could be in any directory, just edit the existing one which is <code>/var/www/html/wp-config.php</code> in your case.

Also, I think the instructions say to create/edit the wp-config.php file simply in the /var/www/ folder when wp-config.php should be in /var/www/html with the other WP files? <br> <br>And I thought the key location was in /home/wp-user/.ssh/ folder not just /home/wp-user/ ? <br>

Getting there! Theme to be uploaded tried to get moved to wp-content/uploads/2014/05, not the themes folder. <br> <br> <br>Also is this what I enter for Authentication keys? <br>http://IP_ADDRESS/home/wp-user/wp_rsa.pub <br>http://IP_ADDRESS/home/wp-user/wp_rsa <br>(This is what I see when trying to add plugins)

Ok I’ll check it out. <br>

We have an article on securely setting up Wordpress auto updates and theme installations: <a href=“https://www.digitalocean.com/community/articles/how-to-configure-secure-updates-and-installations-in-wordpress-on-ubuntu”>https://www.digitalocean.com/community/articles/how-to-configure-secure-updates-and-installations-in-wordpress-on-ubuntu</a>. I believe you can replace <code>wp-user</code> with your own non-root user.