Question

This site can’t be reached but DNS appears configured

Posted August 26, 2020 250 views
UbuntuWordPress

A few days ago I registered my site (waddlebrewery.ca). I kept getting “This site can’t be reached” on Google. I assumed the DNS hadn’t updated but looking on whois, it appears to have updated.

I followed this tutorial. Anyone have any idea of what I may have done wrong. Happy to send anymore photos, if needed.

Here is a photo of my domain page. I have installed and re-installed many times just in case I did something wrong- but I may be making an installation mistake. I am a newb to this all lol. Thanks!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Wait all of a sudden it appears to be working. I didn’t have the A tag but added it right before I posted this. Could that be why it works now?

  • Hi @harrisons1,

    Yes, this is the reason why. You need an A record in order for your DNS to work properly.

    Having said that I take it, you added the A record prior to taking the screenshot provided in your initial question, correct?

    Regards,
    KFSys

    • Thanks for the response KFSys,
      Yeah I added the A record a matter of minutes before I posted this. Ok that’s great. Is there anything else I need to add that may not have been posted in that tutorial? Thanks.

      • I have set a WordPress website up using that tutorial, and I see that it has everything you need to set your website up. Even adding the A record is included in its content too. If you follow the tutorial step by step, you will not have any problems.

        Because you didn’t enable HTTPS during the initial setup script, I recommend configuring it manually. It’s free, and you only need to run one command after logging into your root account over SSH: certbot --apache -d waddlebrewery.ca -d www.waddlebrewery.ca

      • As @tomnguyen,

        Since your DNS didn’t work executing the certbot command should do the trick and be enough to start going forward!

        Great to hear everything is working.

Submit an Answer