Question

Thunderbird does not connect to Dovecot. Webmail is ok.

I set up my mail server with Postfix (MTA) and Dovecot (IMAP, POP3). When I tested my installation with an open source webmail interface everthing has been working well: login with username and password, receive mails (port 993, ssl/tls) and send mails (port 587, starttls). Today I started testing local clients beginning with Thunderbird. Here I get an error message like this: Click Me.

In Dovecot I have already changed

ssl_protocols = !SSLv3 !SSLv2
to
ssl_protocols = TLSv1.2 TLSv1.1 TLSv1 !SSLv3 !SSLv2

Moreover I tried to deactivate the OCSP certificate validation in Thunderbird (Settings > Enhanced > Certificates > Validation)

But the issue keeps existing :( Anyone here to help me please?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

From the question linked here and other conversation on the internet, it seems as if there is a bug in Thunderbird. It looks like Thunderbird fails to prompt the user to accept a self-signed certificate.

One work around seems to be importing the certificate manually through Thunderbird’s certificate setting menu. You can find it through Preferences > Advanced > Certificates > View Certificates:

Import cert