Question

TigerVNC / Centos Tutorial please?

  • Posted April 10, 2014

I can get VNC installed, and Xfce, but I cannot connect remotely with any viewers. tried many ports and still no go. Was using this tutorial http://wiki.centos.org/HowTos/VNC-Server?highlight=(tigervnc)

I am guessing its in the IP tables cat iptables

Generated by iptables-save v1.4.7 on Mon Dec 23 15:32:07 2013

*filter :INPUT ACCEPT [396:30624] :FORWARD ACCEPT [0:0] :OUTPUT ACCEPT [216:23216] -A INPUT -m state --state ESTABLISHED,RELATED -j ACCEPT -A INPUT -p icmp -j ACCEPT -A INPUT -i lo -j ACCEPT -A INPUT -i eth1 -j ACCEPT -A INPUT -m state --state NEW -m tcp -p tcp --dport 22 -j ACCEPT -A INPUT -m state --state NEW -m tcp -p tcp -m multiport --dports 5901:5903,6001:6003 -j ACCEPT -A INPUT -j REJECT --reject-with icmp-host-prohibited -A FORWARD -j REJECT --reject-with icmp-host-prohibited COMMIT

VNC config

cat /etc/sysconfig/vncservers

The VNCSERVERS variable is a list of display:user pairs.

Uncomment the lines below to start a VNC server on display :2

as my ‘myusername’ (adjust this to your own). You will also

need to set a VNC password; run ‘man vncpasswd’ to see how

to do that.

DO NOT RUN THIS SERVICE if your local area network is

untrusted! For a secure way of using VNC, see this URL:

http://kbase.redhat.com/faq/docs/DOC-7028

Use “-nolisten tcp” to prevent X connections to your VNC server via TCP.

Use “-localhost” to prevent remote VNC clients connecting except when

doing so through a secure tunnel. See the “-via” option in the

`man vncviewer’ manual page.

VNCSERVERS=“1:root” VNCSERVERARGS[1]=“-geometry 800x600”

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

I think I should start with a known working tutorial, then if I have issue I can try to troubleshoot them. You are correct it wasn’t started, I forgot to re-install VNC for the 5th attempt, I need a working LAMP platform more than VNC at the moment so I will wait until someone puts together a working tutorial before trying again.

How about “ps -e | grep vnc” Was there any output when you ran <br> <br><pre> <br>/sbin/service vncserver start <br></pre> <br> <br>It doesn’t sound like the VNC server is started.

Got nothing from the <br>netstat -tulp | grep vnc <br>command. Just returns # <br> <br>I can putty into the unit with the ip/root/passwd without issue. <br>TightVNC viewer times out when trying to connect :5901 <br> <br> <br> <br>

You should be able to connect via 5901. Are you getting any kind of error when you try to connect? On the server, what’s the output of: <br> <br>netstat -tulp | grep vnc <br> <br>From another computer, can you connect to the server with: <br> <br>telnet 107.170.114.237 5901 <br> <br>Also, I’d encourage you to set up a non-root user to access VNC.