Question

timthumb permissions

  • Posted on January 17, 2014
  • artimegAsked by artimeg

My droplet is running Ubuntu with Virtualmin installed and has 2 virtual servers. There is the main server, then a sub-server.

My sub-server is where I am testing and running into problems.

I am using the following wordpress plugin: http://codecanyon.net/item/justified-image-grid-premium-wordpress-gallery/2594251 which uses timthumb to generate the thumbnails.

Inside the justified image grid plugin folder are the plugin files and timthumb.php and it’s cache folder that has an index.html file and timthumb_cacheLastCleanTime.touch

I have tried just about every combination of chmod and chown on the timthumb related files and folder.

Here is the error I get in the log: [Fri Jan 17 04:51:57 2014] [error] [client 75.132.160.71] PHP Warning: touch(): Utime failed: Permission denied in /home/artimeg/domains/beta.artimeg.com/public_html/wp-content/plugins/justified-image-grid/timthumb.php on line 206, referer: http://beta.artimeg.com/2013/10/30/image-post/

http://beta.artimeg.com/2013/10/30/image-post/ is a post for testing. In the log file I get the following: GET http://beta.artimeg.com/wp-content/plugins/justified-image-grid/timthumb.ph…om/wp-content/uploads/Avenged-Sevenfold_760_20131011.jpg&h=280&q=90&f=.jpg 400 (Bad Request)

The image file does exist as you can see: http://beta.artimeg.com/wp-content/uploads/Avenged-Sevenfold_760_20131011.jpg

I am at a loss for ideas, so any help is much appreciated!


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

sudo chown www-data -R /var/www/timthumb-folder

Got it working! <br> <br>I think it was a combination of permissions and GD Library. <br> <br>Once the permissions were ok, the site gave me an error stating that the GD Library was not installed. Once I got that installed, everything is working! <br> <br>Thank you for the help!

I’ve tried setting the folder and files to 777 and tried users: root and www-data <br> <br>I deleted the folder, re-created it and still no luck. <br> <br>I also restarted apache after making the changes.