Question

Tomcat on Ubuntu has a 404 error

After I installed the Tomcat and deployed the war file, I can only access the index.html, nothing else. When I was trying get to other page, HTTP Status 404 page will come out. “description The requested resource is not available.”

The following is access_log in tomcat folder. ==> localhost_access_log.2015-09-14.txt <== 76...* - - [14/Sep/2015:14:03:35 -0400] “GET /server/Scripts/angular-route.min.js HTTP/1.1” 200 3947 76...* - - [14/Sep/2015:14:03:35 -0400] “GET /server/Scripts/i18n/angular-locale_en-us.js HTTP/1.1” 200 2013 76...* - - [14/Sep/2015:14:03:35 -0400] “GET /server/Scripts/ng-flow-standalone.min.js HTTP/1.1” 200 18004 76...* - - [14/Sep/2015:14:03:35 -0400] “GET /server/js/HomeController.js HTTP/1.1” 404 1048 76...* - - [14/Sep/2015:14:03:35 -0400] “GET /server/js/CarSellingController.js HTTP/1.1” 404 1060 76...* - - [14/Sep/2015:14:03:35 -0400] “GET /server/js/app.js HTTP/1.1” 200 2111 76...* - - [14/Sep/2015:14:03:35 -0400] “GET /server/js/UniversityController.js HTTP/1.1” 404 1060 76...* - - [14/Sep/2015:14:03:35 -0400] “GET /server/js/CarInfoController.js HTTP/1.1” 200 3204 76...* - - [14/Sep/2015:14:03:35 -0400] “GET /server/Scripts/angular.min.js HTTP/1.1” 200 106653 76...* - - [14/Sep/2015:14:03:36 -0400] “GET /server/template/en-us/stateSelect.html HTTP/1.1” 200 2853 76...* - - [14/Sep/2015:14:28:18 -0400] “GET /user/regist.do HTTP/1.1” 404 1022 76...* - - [14/Sep/2015:14:28:18 -0400] “GET /favicon.ico HTTP/1.1” 200 21630 76...* - - [14/Sep/2015:14:29:28 -0400] “GET /server HTTP/1.1” 302 - 76...* - - [14/Sep/2015:14:29:29 -0400] “GET /server/ HTTP/1.1” 200 5468 76...- - [14/Sep/2015:14:29:29 -0400] “GET /Content/bootstrap.min.css HTTP/1.1” 404 1044 76... - - [14/Sep/2015:14:29:29 -0400] “GET /Content/taocar.css HTTP/1.1” 404 1030 76...* - - [14/Sep/2015:14:29:29 -0400] “GET /Content/font-awesome.min.css HTTP/1.1” 404 1050 76...* - - [14/Sep/2015:14:29:29 -0400] “GET /Scripts/bootstrap.min.js HTTP/1.1” 404 1042 76...* - - [14/Sep/2015:14:29:29 -0400] “GET /Scripts/jquery-1.9.1.js HTTP/1.1” 404 1040 76...* - - [14/Sep/2015:14:29:29 -0400] “GET /Scripts/jquery.easing.min.js HTTP/1.1” 404 1050 76...* - - [14/Sep/2015:14:29:29 -0400] “GET /Scripts/grayscale.js HTTP/1.1” 404 1034 76...* - - [14/Sep/2015:14:29:29 -0400] “GET /img/gt_favicon.png HTTP/1.1” 404 1030


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Anyone here?