Question

Transfer files with scp - getting older files

I am able to do scp from local to a specific directory. I just tried copying down an sql dump from my local.

scp -r root@X.X.X.X:/home/userme ./

With this, it does download files, but I got a really old sql that I have since deleted. When I try to do specific newer files, it says: ‘No such file or directory’

I have not succeeded in the direction of doing it from the droplet terminal down to my local. I get permission denied when I tried that.

I had a lot of success of doing images (wp-content) from local up and down to the droplet. Looks like I had success with an sql file as well (this was two weeks ago). But today it is giving me old files.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi @leorawe,

It’s the matter of what you have at the location you are doing the scp on your droplet.

You might be getting old files just because the files in there are that old. What I’ll recommend is to SSH to your droplet go to the directory you wish to download the files there and list them - ls. Check what’s the proper name, what have you been downloading and so on.

All on all, I don’t think the issue is with SCP rather than with the content of the directory you are downloading from.

Regards, KFSys