Transferring several WordPress websites from shared hosting

  • Posted on September 21, 2013
  • D3m055Asked by D3m055

Hi I have Issue transferring several websites from shared hosting. While transferring I used How to Set Up Multiple WordPress Sites on a Single Ubuntu VPS and How to Migrate WordPress from Shared Hosting to a Cloud Server with Zero Downtime tutorials(!). What I have to do is to transfer about 10 websites from shared hosting to digital ocean. At shared hosting I had 3 dbases:

  1. arkbonline
  2. arkbonline_laconsta
  3. arkbonline_tree - the last base was used by most of those 10 websites, they had different prefixes. arkbonline_laconsta - had only one website With the help of How to Migrate WordPress from Shared Hosting to a Cloud Server with Zero Downtime tutorial it was pretty easy to transfer website. Now it has its own database with the same name but different username.

The second website used arkbonline_tree database. I’ve restored the sql script to a new database with a different name - let’s call it tree_ocean. Created new SQL user for this new restored database. Then I set up all the virtual hosting stuff and uploaded contents of the wordpress website to digital ocean. After updating DNS the issue I face is that the website sends me to /wp-admin/install.php page. It does not display any error message. It simply thinks that it is clean installation of Wordpress. I’ve tried to reinstall it several times. But every time I get /wp-admin/install.php page. I didnt face this issue with the first WP website. What would you recommend me check?

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Awesome! Glad to hear that! :]

It worked! Thank you! I also had to update new prefix in DB as WP was saying that I had no rights to see this page, after attempt to log in. <br>Again, Thank You so Much!

Try setting $table_prefix to ‘as_’ (not ‘aS_’). Does that fix it?