Question

Trouble setting up Ghost droplet on https vs http

I’m trying to create a Ghost droplet via one-click and DNS hosting via Cloudflare, but I’m having trouble accessing the site over https (or a browser like Chrome that automatically uses https). It works on http.

http://blog.hewsan.me - Works https://blog.hewsan.me - Doesn’t work

I haven’t logged in with SSH and started the one-click process yet. Just want to get it right before trying to start that. I know that Ghost will ask for the url for setup - and I want to put in the https address not the http address.

I’ve been reading about the installing the Let’s Encrypt SSL: https://www.digitalocean.com/community/questions/website-can-t-be-reached-err_connection_refused - but I can’t actually do anything. When I login with SSH, it automatically starts the Ghost install process and won’t let me do anything like the initial server setup, etc.

Any thoughts?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi there @panghews,

What is the exact error that you get when visiting your blog via HTTPS?

What I could suggest is setting the Cloudflare SSL to Flexible, that way you would not have to install an SSL certificate on your server and you could keep the Ghost configuration set to HTTP.

Let me know how it goes. Regards, Bobby