Troubleshoot Mail Server Using DigitalOcean Tutorial?

June 15, 2017 343 views
Networking Email Ubuntu 16.04

I followed the tutorial https://www.digitalocean.com/community/tutorials/how-to-configure-a-mail-server-using-postfix-dovecot-mysql-and-spamassassin to try and get a mail server running at home. I'm on Comcast, however, who blocks port 25, so I added this into the config in order to use the Comcast relay. This is the only thing I did differently.

relayhost = [smtp.comcast.net]:587
smtp_sasl_auth_enable = yes
smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
smtp_sasl_security_options =

I then made a file /etc/postfix/sasl_passwd and put:

smtp.comcast.net        COMCASTUSERNAME:COMCASTPASSWORD

As far as I'm aware, this should work, but when I put in the details in Gmail it says it can't reach the server. As for Gmail, I have:

SMTP Server: mydomain.net
Port: 25 [Since I'm using the relay, I'm assuming my end should be configured to 587 and outside should be pointed to 25, although I did try 587 on Gmail, too, to no avail.]
Username: email3@mydomain.net [I have 3 test accounts]
Password: [That account's password]
And I have "Secured connection using TLS" bubbled.

How should I go about troubleshooting this?
Thanks.

1 Answer

@forestman11

I've not personally tried this with Comcast, so I can't verify that this indeed works, though I'd check:

https://sysmgr.org/blog/2013/05/26/sending_postfix_mail_via_comcast_smtp/

From there, if you run in to any issues, reply back and we can try to troubleshoot from there :-).

  • Thanks for the reply! I tried doing this although I'm not sure how to do the SASL bit on Ubuntu since the tutorial is for SmartOS. I did everything else, however, but it still doesn't work. To be completely honest, I'm not even sure if I'm using the correct parameters in Gmail as I'm new to all this.

    • @forestman11

      No problem at all :-).

      For sasl you'd want to run:

      apt-get -y install sasl2-bin
      

      You would then need to reconfigure postfix by running (see note below, i.e. the Before).

      dpkg-reconfigure postfix
      

      Before you run that command, I would backup any configuration that you currently have just in case it's overwritten since you'll run through the setup again. That way you have a backup to refer to for your current configuration (I like to do this just so I'm not having to recall everything from memory).

      That said, running a mail server can be a bit complex and successfully running one without any issues can be a bit of a pain from time to time (I've managed a few over the last 10 or so years :) ).

      This is often more so true when you're trying to setup a home mail server that runs through another provider that is a bit more restrictive on how their customers use their services.

      Let's see if that helps, and if not, let me know what error(s) you're seeing then, or if it's the same.

Have another answer? Share your knowledge.