Trying to add a second domain to my webapp, It it normal to take 2 weeks?

In my webapp domain setting, One domain is active and started working within hours. A week later I tried to connect a new domain, and it has said “configuring” for over 2 weeks now.

Is this normal? I have desired to leave it for 2 weeks and before i tried other ways. Having digital ocean manage the domain and having google manage the domain. But still nothing

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.


I have just tested this and it worked quite quickly, only took some minutes. Usually the domain name would get stuck in a Configuring stage if the CNAME record is not correct.

You need to make sure that the CNAME record is added under the active DNS zone of the domain, meaning that depending on what NameServers you are using, you need to add the CNAME record under the respective DNS zone and DNS provider.

In the above screenshot, you can see that the new domain that I’ve added called is active already, and the first domain called is not because its CNAME record is not correct.

If you are still seeing the problem, I could suggest contacting the DigitalOcean support team so that they could further investigate this for you.

Best, Bobby