trying to deploy using capistrano. stuck at cap deploy:cold (getting a weird error)

January 28, 2014 2.7k views
Hi, I am following this guide https://coderwall.com/p/yz8cha everything went well, until i reached cap deploy:cold where I get the following error : *** [deploy:update_code] rolling back * executing "rm -rf /home/harris/harrisrobin.co/releases/20140128225905; true" servers: ["198.199.122.209"] [198.199.122.209] executing command command finished in 354ms failed: "rvm_path=$HOME/.rvm $HOME/.rvm/bin/rvm-shell 'default' -c 'cd -- /home/harris/harrisrobin.co/releases/20140128225905 && RAILS_ENV=production RAILS_GROUPS=assets bundle exec rake assets:precompile'" on 198.199.122.209 I do not know how to interpret this.
3 Answers
Try ssh-ing into your droplet as "harris" and running rvm_path=$HOME/.rvm $HOME/.rvm/bin/rvm-shell 'default' -c 'cd -- /home/harris/harrisrobin.co/releases/20140128225905 && RAILS_ENV=production RAILS_GROUPS=assets bundle exec rake assets:precompile manually—does it return any errors?

got stuck in the same situation. Please help...

command finished in 59140ms

*** [deploy:update_code] rolling back

  • executing "rm -rf /home/deployer/apps/tiangge/releases/20150123133459; true" servers: ["128.199.74.8"] [128.199.74.8] executing command command finished in 1617ms failed: "rvm_path=$HOME/.rvm $HOME/.rvm/bin/rvm-shell 'default' -c 'cd /home/deployer/apps/tiangge/releases/20150123133459 && bundle install --gemfile /home/deployer/apps/tiangge/releases/20150123133459/Gemfile --path /home/deployer/apps/tiangge/shared/bundle --deployment --quiet --without development test'"

Facing the same situation.. let me know if you have found a solution.

Have another answer? Share your knowledge.