I tried to install PHPMyAdmin but I kept getting an error, something about not being able to connect through the socket(s). This was after going through the setup of setting passwords and administrator accounts etc.

I didn’t have LAMP, mysql, or PHP installed yet so I uninstalled PHPMyAdmin by purge removing it and deleting the phpmyadmin folder in /etc.

Now when I try to sudo apt-get install phpmyadmin, it asks me if I want to use apache2, and after I say ok, the installation just finishes. I try to go to http://myhost/phpmyadmin and it asks for root@localhost’s password which I don’t have because it doesn’t take me through the installation anymore.

I’m trying to follow this tutorial, and for me it’s stopping after apache2 without any (visible) errors. It’s not asking for dbconfig-common like it did the first time I tried to install.

Thanks

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

The tutorial you linked assumes you have LAMP setup. It seems like you were missing that. If you’re not familiar with CLI, you can build server with a control panel like Virtualmin which has one-click phpmyadmin install feature.

edited by MattIPv4
Submit an Answer