Question

TTFB is very long using Cloudflare

Hi everyone!

The issue I run into is that when I upload files I chunk them into smaller pieces. After each chunk a new request gets sent. These requests have a long TTFB waiting time as you can see here:

screenshot

It takes 1.2 mins to upload 50mb and then 30 seconds to respond from Cloudflare to my server in order to start the next 50mb chunk.

Is there a way I can disable Cloudflare for http://testnow.ga/jquery-file-upload only and not for http://testnow.ga/ ?

I would appreciate any help!

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

@Woet Thanks for that post but it doesn’t affect my case, because I am uploading data which seems to be processed on Cloudflare’s end. It is not meaningless as they say, when it adds an extra 7 minutes of waiting when the user is uploading a 300mb file. Other than that I do agree with them if it does not hurt your SEO.

Thanks for the response! I figured it would only be available through subdomains. I wish that would be a possibility on my end to set up a sub domain. :-( Seems like I just need to do some better caching on my end. Shouldn’t be too hard and on top of it all the popular libraries are available as CDNs anyways.

@Chris1904

I’m not sure if this is possible on the pay accounts, though it’s not possible to disable specific URL’s on their free accounts.

The only way around this that I can think of would be to setup a sub-domain, disable that sub-domain within the CloudFlare control panel (you’d still need to set it up so that they’re aware of it), and then use the sub-domain to access your upload script.