Turned on private networking; no new interface

March 3, 2016 2.6k views
Networking Configuration Management Ubuntu

I turned off my droplet, enabled private networking, and observed in the control panel that it now has a private IP address. All well and good. So I ssh'd into the droplet, tried to ping the private IP of another droplet, and nothing happened. So I ran ifconfig and, lo and behold, there was no eth1 interface, so no connection to the private network. Any ideas?

2 Answers

Ah, apparently there's a step four: manually configure private networking.

Thank you to the speedy DigitalOcean support staff :)

by Melissa Anderson
DigitalOcean offers shared private networking for Droplets in all data centers at no additional charge. When private networking is enabled as part of creating a Droplet, it is automatically configured. If it's not set up when the Droplet is created, it can be enabled manually. In this article, we'll explain how to enable and manually configure private networking for Droplets that were created without private networking.
  • Yeah, that step 3 makes it feel like you're done... Thanks for posting this!

  • After following step 4 I still can't see the eth1. Which linux kernel are you running?
    This is on Ubuntu server 14.04.5

Have another answer? Share your knowledge.