I am following a tutorial to setup php on Digitial Ocean and am using the web console.

I am trying to enter a “<” in a php file and all it types is “>”

I’ve also tried the same in a html and txt file with the same result, same issue with trying to paste in the “<”.

Also posted here with screenshot:



These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

1 answer

Hey Joe

This is an especially frustrating known bug with the software that powers DigitalOcean’s web console, more info on the bug here: https://lists.gnu.org/archive/html/qemu-devel/2018-12/msg04631.html

Option 1:
I haven’t tested it myself, but if you are on a windows device you may be able to use the “ALT + NUMPAD” system to enter the exact decimal character code of the “<” char.

To try it out, hold down ALT key, type 060 on your numpad and release ALT. More reference here: http://www.irongeek.com/alt-numpad-ascii-key-combos-and-chart.html

Option 2:
Generally, we recommend switching to a full-fledged terminal app like Putty on Windows or the included terminal on OSX and Linux - to take that approach follow the instructions here: https://www.digitalocean.com/docs/droplets/how-to/connect-with-ssh/

Submit an Answer