I am following a tutorial to setup php on Digitial Ocean and am using the web console.

I am trying to enter a “<” in a php file and all it types is “>”

I’ve also tried the same in a html and txt file with the same result, same issue with trying to paste in the “<”.

Also posted here with screenshot:
https://superuser.com/questions/1397557/typing-in-nano-through-digital-ocean-console

Regards,

Joe

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
2 answers

Hey Joe

This is an especially frustrating known bug with the software that powers DigitalOcean’s web console, more info on the bug here: https://lists.gnu.org/archive/html/qemu-devel/2018-12/msg04631.html

Option 1:
I haven’t tested it myself, but if you are on a windows device you may be able to use the “ALT + NUMPAD” system to enter the exact decimal character code of the “<” char.

To try it out, hold down ALT key, type 060 on your numpad and release ALT. More reference here: http://www.irongeek.com/alt-numpad-ascii-key-combos-and-chart.html

Option 2:
Generally, we recommend switching to a full-fledged terminal app like Putty on Windows or the included terminal on OSX and Linux - to take that approach follow the instructions here: https://www.digitalocean.com/docs/droplets/how-to/connect-with-ssh/

Hello, all

The Droplet web console provides out-of-band access and is available regardless of your network settings. It emulates the access you would have if you were sitting down with a keyboard and monitor attached to the actual server. You can use this feature to log in and revert bad settings to regain normal access.

You can check our official docs for the console here:

https://www.digitalocean.com/docs/droplets/resources/console/

You will usually use the console if you can’t access your droplet using ssh via a ssh client and it’s usually the last resort option when it comes to troubleshooting.

You can also check our docs on How to Connect to Droplets with SSH:

https://www.digitalocean.com/docs/droplets/how-to/connect-with-ssh/

There are two options at the bottom of the doc:
Connect with OpenSSH
and
Connect with PuTTY

Hope that this helps!
Regards,
Alex

Submit an Answer