Question

Ubuntu 14.04.5 x64 Apache - Showing Index Of/ instead of index.html?

Posted August 19, 2016 6.5k views
UbuntuApacheDeployment

Good day, I’ve set up my server online over DigitalOcean, I followed their guides on how to set up an Ubuntu 14.04.x x64 server, setting up a LAMP stack, and installing phpMyAdmin. Everything is working fine, the mySite.com shows the apache setup page. However, when I uploaded my new index.html (located at /var/www/html/index.html) file (I renamed the default one to index-default.html) and then refreshed my site, instead of showing my site, it shows Index Of/. I tried mySite.com/index.html and it works. It’s just a bit of a hassle to have the user type in mySite.com/index.html and I know it can work with just mySite.com. I opened up FileZilla to check if this may be caused by the difference of the permissions and ownership, and they were initially different. I updated the permissions and ownership and now they have the same sets.

The permission is -rwxrwxr-x and then the Owner/Group has been set to www-data www-data and now I’m just confused as to how to proceed with this.

Basically I want the site to show my index.html just by going to mySite.com.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Fixed it.

I ran sudo nano /etc/apache2/mods-enabled/dir.conf

And then I saw that it didn’t say index.html. It had index.php twice.

It now reads

<IfModule mod_dir.c>
    DirectoryIndex index.html index.cgi index.pl index.php index.xhtml index.htm
</IfModule>
Submit an Answer