Question

Ubuntu 14.04: apt-get update "404 not found issue"

  • Posted January 8, 2015

I just created a new droplet and attempted to run sudo apt-get update as part of the LAMP tutorial and was hit with a bunch of 404 not found errors (see below). Is there an issue with the mirror currently?

root@EOTNS:~# sudo apt-get update
Ign http://security.ubuntu.com trusty-security InRelease
Hit http://security.ubuntu.com trusty-security Release.gpg
Hit http://security.ubuntu.com trusty-security Release
Hit http://security.ubuntu.com trusty-security/main Sources
Hit http://security.ubuntu.com trusty-security/universe Sources
Hit http://security.ubuntu.com trusty-security/main amd64 Packages
Ign http://mirrors.digitalocean.com trusty InRelease
Hit http://security.ubuntu.com trusty-security/universe amd64 Packages
Hit http://security.ubuntu.com trusty-security/main i386 Packages
Hit http://security.ubuntu.com trusty-security/universe i386 Packages
Ign http://mirrors.digitalocean.com trusty-updates InRelease
Hit http://security.ubuntu.com trusty-security/main Translation-en
Hit http://security.ubuntu.com trusty-security/universe Translation-en
Ign http://mirrors.digitalocean.com trusty Release.gpg
Ign http://mirrors.digitalocean.com trusty-updates Release.gpg
Ign http://mirrors.digitalocean.com trusty Release
Ign http://mirrors.digitalocean.com trusty-updates Release
Err http://mirrors.digitalocean.com trusty/main Sources
  404  Not Found [IP: 192.241.164.26 80]
Err http://mirrors.digitalocean.com trusty/universe Sources
  404  Not Found [IP: 192.241.164.26 80]
Err http://mirrors.digitalocean.com trusty/main amd64 Packages
  404  Not Found [IP: 192.241.164.26 80]
Err http://mirrors.digitalocean.com trusty/universe amd64 Packages
  404  Not Found [IP: 192.241.164.26 80]
Err http://mirrors.digitalocean.com trusty/main i386 Packages
  404  Not Found [IP: 192.241.164.26 80]
Err http://mirrors.digitalocean.com trusty/universe i386 Packages
  404  Not Found [IP: 192.241.164.26 80]
Ign http://mirrors.digitalocean.com trusty/main Translation-en_US
Ign http://mirrors.digitalocean.com trusty/main Translation-en
Ign http://mirrors.digitalocean.com trusty/universe Translation-en_US
Ign http://mirrors.digitalocean.com trusty/universe Translation-en
Err http://mirrors.digitalocean.com trusty-updates/main Sources
  404  Not Found [IP: 192.241.164.26 80]
Err http://mirrors.digitalocean.com trusty-updates/universe Sources
  404  Not Found [IP: 192.241.164.26 80]
Err http://mirrors.digitalocean.com trusty-updates/main amd64 Packages
  404  Not Found [IP: 192.241.164.26 80]
Err http://mirrors.digitalocean.com trusty-updates/universe amd64 Packages
  404  Not Found [IP: 192.241.164.26 80]
Err http://mirrors.digitalocean.com trusty-updates/main i386 Packages
  404  Not Found [IP: 192.241.164.26 80]
Err http://mirrors.digitalocean.com trusty-updates/universe i386 Packages
  404  Not Found [IP: 192.241.164.26 80]
Ign http://mirrors.digitalocean.com trusty-updates/main Translation-en_US
Ign http://mirrors.digitalocean.com trusty-updates/main Translation-en
Ign http://mirrors.digitalocean.com trusty-updates/universe Translation-en_US
Ign http://mirrors.digitalocean.com trusty-updates/universe Translation-en
W: Failed to fetch http://mirrors.digitalocean.com/dists/trusty/main/source/Sources  404  Not Found [IP: 192.241.164.26 80]

W: Failed to fetch http://mirrors.digitalocean.com/dists/trusty/universe/source/Sources  404  Not Found [IP: 192.241.164.26 80]

W: Failed to fetch http://mirrors.digitalocean.com/dists/trusty/main/binary-amd64/Packages  404  Not Found [IP: 192.241.164.26 80]

W: Failed to fetch http://mirrors.digitalocean.com/dists/trusty/universe/binary-amd64/Packages  404  Not Found [IP: 192.241.164.26 80]

W: Failed to fetch http://mirrors.digitalocean.com/dists/trusty/main/binary-i386/Packages  404  Not Found [IP: 192.241.164.26 80]

W: Failed to fetch http://mirrors.digitalocean.com/dists/trusty/universe/binary-i386/Packages  404  Not Found [IP: 192.241.164.26 80]

W: Failed to fetch http://mirrors.digitalocean.com/dists/trusty-updates/main/source/Sources  404  Not Found [IP: 192.241.164.26 80]

W: Failed to fetch http://mirrors.digitalocean.com/dists/trusty-updates/universe/source/Sources  404  Not Found [IP: 192.241.164.26 80]

W: Failed to fetch http://mirrors.digitalocean.com/dists/trusty-updates/main/binary-amd64/Packages  404  Not Found [IP: 192.241.164.26 80]

W: Failed to fetch http://mirrors.digitalocean.com/dists/trusty-updates/universe/binary-amd64/Packages  404  Not Found [IP: 192.241.164.26 80]

W: Failed to fetch http://mirrors.digitalocean.com/dists/trusty-updates/main/binary-i386/Packages  404  Not Found [IP: 192.241.164.26 80]

W: Failed to fetch http://mirrors.digitalocean.com/dists/trusty-updates/universe/binary-i386/Packages  404  Not Found [IP: 192.241.164.26 80]

E: Some index files failed to download. They have been ignored, or old ones used instead.
root@EOTNS:~#

Subscribe
Share

FYI, I ran into this earlier, but after running an apt-get update before the install/upgrade everything went swimmingly. Thanks!

FYI, I ran into this earlier, but after running an apt-get update before the install/upgrade everything went swimmingly. Thanks!

FYI, I ran into this earlier, but after running an apt-get update before the install/upgrade everything went swimmingly. Thanks!

I created a ticket and got the following response.

Hello,

Our Engineering Team and I are currently investigating a possible issue with our mirrors.

I will update you as soon as more information is available.

I created a ticket and got the following response.

Hello,

Our Engineering Team and I are currently investigating a possible issue with our mirrors.

I will update you as soon as more information is available.

how to resolve it!!

Same issue =/

See @C60 's comment! ++++++100001201010101111! <3

Just tried this and getting the same problem with ubuntu 14.10.

I’m having this same issue on my Ubuntu droplet but I already have the sources as listed, with the /ubuntu/ on the end.


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Support was able to help me get this resolved by having me run: rm -rf /var/lib/apt/lists/partial/*

Then running the update again.

Support was able to help me get this resolved by having me run: rm -rf /var/lib/apt/lists/partial/*

Then running the update again.

Support was able to help me get this resolved by having me run: rm -rf /var/lib/apt/lists/partial/*

Then running the update again.

Support was able to help me get this resolved by having me run: rm -rf /var/lib/apt/lists/partial/*

Then running the update again.

Support was able to help me get this resolved by having me run: rm -rf /var/lib/apt/lists/partial/*

Then running the update again.

Support was able to help me get this resolved by having me run: rm -rf /var/lib/apt/lists/partial/*

Then running the update again.

Support was able to help me get this resolved by having me run: rm -rf /var/lib/apt/lists/partial/*

Then running the update again.

Again:

Hit http://mirrors.digitalocean.com trusty/main Translation-en Err http://mirrors.digitalocean.com trusty-backports/main Sources

Err http://mirrors.digitalocean.com trusty-backports/restricted Sources Bad header line [IP: 95.85.0.50 80] Err http://mirrors.digitalocean.com trusty-backports/universe Sources Bad header line [IP: 95.85.0.50 80] Err http://mirrors.digitalocean.com trusty-backports/main Sources 0 Requested Range Not Satisfiable [IP: 95.85.0.50 80] Err http://mirrors.digitalocean.com trusty-backports/multiverse Sources 404 Not Found [IP: 95.85.0.50 80] Err http://mirrors.digitalocean.com trusty-backports/main i386 Packages Bad header line [IP: 95.85.0.50 80]

This comment has been deleted

I retried the command today without any changes to see what would happen and it was successful. Ill assume it was on their end and they resolved the issue.

Thank you all for your comments and thanks kakeiso97 for your suggestion, but I didn’t get a chance to try it.