Question

UBUNTU 14.4 apache2 2.4 attempting to call a perl script from javascript on client yields the text of the file rather than executing it.

I can not find a configuration error. Help.

UBUNTU 14.4 apache2 2.4 attempting to call a perl script from gavascript on client yields the text of the file rather than executing it. I can not find a configuration error. Help. The perl script will execute correctly from the command line.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

In order for a perl script to be executed by Apache you need to set up the cgi module. To do this:

enable the CGI module

a2enmod cgi

By default, perl scripts are only allowed to be executed from /usr/lib/cgi-bin. In order to run them within your web root you will need to adjust your Apache configuration. If you are using a default configuration you will need to edit the config file in /etc/apache2/sites-enabled/ so it reflects:

<Directory "/var/www/html">
    Options +ExecCGI
    AddHandler cgi-script .cgi .pl
</Directory>

Now restart apache so the changes you’ve made take effect:

service apache2 restart